Changes in the IDE from 4.0 to 4.2

Last edited on

Reorganized menus

In Squish 4.2 the menu entries from the “Squish” menu in the menubar have been moved to more apropriate places. The “Squish” menu started to accumulate completely unrelated entries and most of them fit much better into other existing menubar entries. The following table lists which entries existed in Squish 4.1 and where they moved to:

Menu Entry in Squish MenuPosition of the Entry in Squish 4.2
Launch AUTRun->Launch AUT
Quit AUTRun->Quit AUT
Record Test CaseRun->Record Test Case
Record SnippetRun->Record Snippet
Run Test SuiteRun->Run Test Suite
Run Test CaseRun->Run Test Case
Close Test SuiteFile->Close Test Suite
Delete Test SuiteFile->Delete Test Suite
Add Symbolic NameDropped from menubar, available on the right side of the Object Map Editor
Manage AUTs…Edit->Server Settings->Manage AUTs… in Standalone IDE and Window->Server Settings->Manage AUTs… when using the Squish Integration for Eclipse
Check Object ExistenceDropped from menubar, available on the right side of the Object Map Editor

In addition to the above since the IDE preferences and the various server settings are relatively close related items we decided to move the Preferences entry in the standalone Squish IDE to the Edit menu to keep them together. The only exception to this is on MacOSX where the Preferences are kept in the Application Menu for the IDE, but unfortunately we could not move the Squish Server Settings there.

Reorganized toolbar

The “Create new Test Suite” and “Open Test Suite” toolbar items in the “Test Suites” view have been moved to the top-level toolbar. The buttons did not work on a specific Test Suite unlike the Object Map and the Test Suite Settings buttons there and moving them away gives the combobox more space to show the Test Suite name.

Additions

Also notable is a new addition to the menus: “Open Symbolic Name” to be found in the Navigate menu when a script editor is open. This entry tries to find a symbolic name based on the editors selection or cursor position and opens the corresponding object map with the symbolic name highlighted.