"dyld could not load inserted library..."

Last edited on

Symptoms

You get an error message similar to this one:

dyld: could not load inserted library: /Users/user/squish-4.x/lib/libsquishqtpre.dylib

Possible causes and Solutions

Qt/Cocoa with non-Pure Qt 4 Squish package

It is necessary to use a Pure Qt 4 Squish binary package when testing Qt/Cocoa applications. If you use a standard non-pure Qt 4 Squish binary package to test a Qt/Cocoa application, you might get this error.

Solution #1: Contact froglogic support and request a Pure Qt 4 Squish binary package.

Solution #2: Build Squish from source: this will automatically prevent the problem. Note that Squish source code is only available to Squish licensees (from their customer area on the froglogic web site); it is not available to evaluators.

Using a Squish PPC package on Intel hardware

The Squish binary package must be for the correct microprocessor. So, for example, if you use a PowerPC (PPC) Squish binary on an Intel-based Mac, you might get this error.

Solution: Choose a Squish binary package that matches your machine’s hardware. Intel package names contain “i386”; PowerPC package names contain “ppc”.

Checking for Qt/Carbon & Qt/Cocoa

To check if an application is built with Qt/Carbon or with Qt/Cocoa, execute the following command:

nm /path/to/QtGui | grep macMenu

The /path/to/QtGui must be the path to the QtGui file used by your application.

The output will contain something like the following if the application uses Qt/Cocoa:

0006ab40 T __ZN5QMenu7macMenuEP6NSMenu

The output will contain something like the following if application uses Qt/Carbon:

0006ab40 T __ZN5QMenu7macMenuEP13OpaqueMenuRef