Ubuntu and Qt library compatibility

Last edited on

Problem

Ubuntu has applied some patches to Qt that are binary incompatible with Squish binary packages provided by froglogic.

Solution

Download the Qt binary from https://www.qt.io/download-qt-installer (alternatively see Using Squish Qt example applications (Qt, Linux).

You only need the libraries. You can install them into a new directory in your user account, and then re-run Squish setup and point to the newly installed libraries in that directory.

Verified with: Ubuntu 10.04 and Qt 4.6, Ubuntu 10.10 and Qt 4.7 (64-bit)